[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PVS-Help] ELF file OS ABI invalid error



Hi Sam!  Thanks much for the reply.  I did google but wasn't finding 
what I was looking for or didn't understand the 2 were related.  Anyway 
I think you were spot on.  All I did was download the 5.x version of PVS 
and it worked like a champ.  The 6.0 version worked on our centos6 
machines without issue.  So this is resolved for me, I just can't run 
pvs 6 on centos 5.x.

Sincerely,

Doug Tucker

On 03/20/2015 03:26 PM, Sam Owre wrote:
> Hi Doug,
>
> I would google for possible answers - from what I can see,
> the PVS image requires newer versions of the kernel and/or glibc.
>
> The answer for you may be in
> https://access.redhat.com/solutions/60371
> I'm not a subscriber (I don't use RedHat myself), so I couldn't see the
> solution.
>
> If you have further questions, I'll be happy to try and help.
> And if you find a solution, please post it here.
>
> Thanks,
> Sam Owre
>
>
> Tucker, Doug <tuckerd@xxxxxxxxxxxx> wrote:
>
>> I'm new to pvs.  I just installed it on our scientific linux 5.7
>> machine.  I downloaded the prebuilt as suggested, untarred it in a
>> directory and ran bin/relocate as the INSTALL file indicated.  When I
>> then launch ./pvs, the emac opens and states the following:
>>
>> Starting pvs-allegro -qq ...
>> dlopen(/usr/local/pvs-6.0/bin/ix86_64-Linux/runtime/libacli9076.so: ELF
>> file OS ABI invalid.
>>
>> Any help would be appreciated.
>>
>> --
>> Sincerely,
>>
>> Doug Tucker
>