[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PVS-Help] PVS on OSX mountain lion



I'm running PVS 5.0 (allegro) in Mac OSX Mountain Lion (and have used PVS
in most intel-based OSX versions) with Aquamacs.

First, make sure that the problem is with PVS and not with emacs. Type the
following in a terminal:

$ pvs -raw

If you get something like:

International Allegro CL Enterprise Edition
8.2 [64-bit Mac OS X (Intel)] (Nov 3, 2011 16:18)
Copyright (C) 1985-2010, Franz Inc., Oakland, CA, USA.  All Rights
Reserved.

This dynamic runtime copy of Allegro CL was built by:
   [TC8101] SRI International

;; Optimization settings: safety 1, space 1, speed 3, debug 1.
;; For a complete description of all compiler switches given the
;; current optimization settings evaluate (explain-compiler-settings).
;;---
;; Current reader case mode: :case-sensitive-lower
; Fast loading /Users/cmunoz/.pvs.n64fasl
pvs(1): 

Then type (quit) and then say y to the question "Do you really want to
kill the PVS process?"

This means that PVS is running fine and that emacs is the problem. In that
case, type

$ pvs -nw

If it works, PVS is running with a non-GUI emacs. To set Aquamacs, make
sure that you have something like:

export PVSEMACS=/Applications/Aquamacs.app/Contents/MacOS/Aquamacs

in you ~/.profile.

Possible errors I have seen in Mac OSX:
* Spaces in the directory where PVS is installed (the pvs script doesn¹t
handle them gracefully)
* PVSEMACS doesn't point to the right directory.

What is the value of $PVSEMACS?

Hope that this helps,

Cesar 

On 10/22/12 9:23 AM, "Jean-Claude Royer"
<Jean-Claude.Royer@xxxxxxxxxxxxxxx> wrote:

>
>Hi all
>I was using PVS on OS X snow leopard and it worked
>but unfortunately changing to mountain lion
>the allegro application is stuck.
>I reinstalled it and tried various options but nothing happens.
>I think that it is related to bug 1082 from Paul Gloess.
>Does anybody has an idea or successfully installed PVS on moutnain lion ?
>
>regards
>
>Jean-Claude.Royer@xxxxxxxxxxxxxxx
>ASCOLA, Mines de Nantes - INRIA
>+ 33 2 51 85 82 05
>
>
>
>
>
>