[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PVS-Help] how use Carbon emacs with pvs4 on Mac



Hi Dave,

I ran into similar problems - I'm not sure I have a real fix, but in my
case it turned out that the /usr/local/Emacs.app was not the right one.
I got the same error just by invoking this at the command line without
involving PVS, which helped me to figure out what was going on.

I'm using Darwinport (aka Macport) on a MacOSX Intel.  I installed
emacs-devel (which has better vc support for svn), and I set my 
PVSEMACS environment variable to

/Applications/MacPorts/Emacs.app/Contents/MacOS/Emacs

It seems to work for me.

Regards,
Sam

David Naumann <naumann@cs.stevens.edu> wrote:

> I used DarwinPorts to install Carbon emacs-22 on an Intel Macbook and
> emacs/AuCTeX/etc work just fine.  I installed the PVS4 pre-built Allegro
> binary for Mac/Intel.  But I can't get it work with emacs.
> I thought I'd just need to give the path to the emacs executable, as in:
> 
>    ./pvs -emacs /usr/local/Emacs.app/Contents/MacOS/bin/emacs
> 
> But I get errors about directories that indeed don't exist:
> 
> -----------
> Warning: arch-dependent data dir
> (/Volumes/Emacs/Emacs.app/Contents/MacOS/libexec/emacs/22.0.50/i386-apple-darwin8.7.1/)
> does not exist.
> Warning: arch-independent data dir
> (/Applications/Emacs.app/Contents/Resources/share/emacs/22.0.50/etc/) does
> not exist.
> emacs: standard input is not a tty
> -----------
> 
> I'm a Mac newbie with no time to tinker, so it would be fine with me if
> someone can suggest an alternate emacs that's easily installed, will work
> with PVS and AuCTeX, and is integrated enough with Carbon/Aqua to do
> cut-and-paste.
> 
> thanks,
> dave