[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PVS-Help] Problem starting up PVS



Hi Robert,

Am I correct in assuming that you're using XEmacs?  What shell do you
use?

The line that's causing you problems was added at the request of one of
our users, and didn't cause me any problems.  However, I only tried it
under bash, where 'LD_ASSUME_KERNEL=2.4.19' is legal.  I'll see if I can
come up with a better solution.

By the way, there is a note on LD_ASSUME_KERNEL in the PVS FAQ on the
Wiki page:

http://pvs-wiki.csl.sri.com/index.php/FAQ#PVS_problems_with_Fedora_Core_5.2C_Redhat_9.2C_or_Enterprise

Feel free to add your own notes there, especially if you have a better
solution that works for all systems.

Thanks,
Sam

Robert P. Goldman <rpgoldman@sift.info> wrote:

> I just upgraded my install from pvs 3.2 to 4.0, on linux, and now I'm
> having a problem starting pvs.  I get the following error:
> [rpg@rpg-sift-inspiron pvs]$ ~/pvs/pvs uav_actions.pvs
> /home/rpg/pvs/pvs: line 327: LD_ASSUME_KERNEL=2.4.19: command not found
> 
> I am running Mandriva Linux:
> [rpg@rpg-sift-inspiron pvs]$ uname -r
> 2.6.12-15mdk-i686-up-4GB
> 
> Any idea what might be causing this?
> 
> I have tried simply removing all the LD_ASSUME_KERNELs, and that seems to
> work.  BTW, I have an ACL license, and run 8.0 all the time w/o any need
> to do this funny stuff with LD_ASSUME_KERNEL.
> 
> Thanks,
> R
> 
> -- 
> Robert P. Goldman
> Senior Scientist
> Smart Information Flow Technologies (d/b/a SIFT, LLC)
> 
> 211 N. First St., Suite 300
> Minneapolis, MN 55401
> 
> Voice:	(612) 384-3454
> Email:    rpgoldman@SIFT.info